# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*"
test_str = ("<html>\n"
" <head>\n"
" <title>#{Subject}</title>\n"
" </head>\n"
" <body>\n"
" <div>StringTest: #{String}</div>\n"
" <div>IntTest: #{Int}</div>\n"
" <div>IntTest: #{INT}</div>\n"
" <div>IntTest: #{int}</div>\n"
" <div>IntTest: #{iNt}</div>\n\n"
" #{ListStart:Documents}\n"
" <div>#{Value}</div>\n"
" #{ListEnd:Documents}\n\n"
" #{ListStart:ExtDocuments}\n"
" <div>#{Id} - #{MeinWert}</div>\n"
" <div>#{Id} - #{MeinWert}</div>\n"
" #{ListEnd:ExtDocuments}\n\n"
" </body>\n"
"</html>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.