const regex = /[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\n\\r\\s]*#{ListStart:ExtDocuments}[\\n\\r]([\\w\\n\\r\\s\\<\\>\\#\\{\\}\\\/\\-]*)#{ListEnd:ExtDocuments}[\\n\\r\\s]*', '')
const str = `<html>
<head>
<title>#{Subject}</title>
</head>
<body>
<div>StringTest: #{String}</div>
<div>IntTest: #{Int}</div>
<div>IntTest: #{INT}</div>
<div>IntTest: #{int}</div>
<div>IntTest: #{iNt}</div>
#{ListStart:Documents}
<div>#{Value}</div>
#{ListEnd:Documents}
#{ListStart:ExtDocuments}
<div>#{Id} - #{MeinWert}</div>
<div>#{Id} - #{MeinWert}</div>
#{ListEnd:ExtDocuments}
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}