import Foundation
let pattern = ##"[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<html>
<head>
<title>#{Subject}</title>
</head>
<body>
<div>StringTest: #{String}</div>
<div>IntTest: #{Int}</div>
<div>IntTest: #{INT}</div>
<div>IntTest: #{int}</div>
<div>IntTest: #{iNt}</div>
#{ListStart:Documents}
<div>#{Value}</div>
#{ListEnd:Documents}
#{ListStart:ExtDocuments}
<div>#{Id} - #{MeinWert}</div>
<div>#{Id} - #{MeinWert}</div>
#{ListEnd:ExtDocuments}
</body>
</html>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}