# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@(\w+?)@/{\1}/g;t' <<< "http://whatever.org/?title=@Title@¬e=@Note@"