use strict;
my $str = 'http://whatever.org/?title=@Title@¬e=@Note@';
my $regex = qr/@(\w+?)@/p;
my $subst = '{\\1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";