package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(\w+?)@`)
var str = `http://whatever.org/?title=@Title@¬e=@Note@`
var substitution = "{\1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}