$re = '/@(\w+?)@/';
$str = 'http://whatever.org/?title=@Title@¬e=@Note@';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;