# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^%]*(%{1}(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)
/IMAGE REMOVED FROM CHROME\r\n/gmix;t' <<< "Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u."