$re = '/([^%]*(%{1}(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)
/mix';
$str = 'Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u.';
$subst = "IMAGE REMOVED FROM CHROME\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;