import Foundation
let pattern = ##"""
([^%]*(%{1}(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = ##"Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"IMAGE REMOVED FROM CHROME\r\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)