import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^%]*(%{1}(\\d+\\$)?[-+\\s0#]?(\\d+|\\*)?(\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\\d+\\$)?[-+\\s0#]?(?:\\d+|\\*)?(?:\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)\n";
final String string = "Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u.";
final String subst = "IMAGE REMOVED FROM CHROME\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}