const regex = /([^%]*(%{1}(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^%]*(%{1}(\\d+\\$)?[-+\\s0#]?(\\d+|\\*)?(\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!.*(?:%{1}(?:\\d+\\$)?[-+\\s0#]?(?:\\d+|\\*)?(?:\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+).*)?)
', 'gmi')
const str = `Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u.`;
const subst = `IMAGE REMOVED FROM CHROME\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);