#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\{((?:[a-f0-9]{2})+)\}"
Local $sString = "abcef7ha43{aabb}7sf6g" & @CRLF & _
"abcef7ha43{aab}7sf6g" & @CRLF & _
"abcef7ha43{0008EFAC}7sf6g" & @CRLF & _
"abcef7ha43{WEA}7sf6g" & @CRLF & _
"abcef7ha43{}7sf6g"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")