use strict;
my $str = 'abcef7ha43{aabb}7sf6g
abcef7ha43{aab}7sf6g
abcef7ha43{0008EFAC}7sf6g
abcef7ha43{WEA}7sf6g
abcef7ha43{}7sf6g';
my $regex = qr/\{((?:[a-f0-9]{2})+)\}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}