const regex = /\{((?:[a-f0-9]{2})+)\}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{((?:[a-f0-9]{2})+)\\}', 'gi')
const str = `abcef7ha43{aabb}7sf6g
abcef7ha43{aab}7sf6g
abcef7ha43{0008EFAC}7sf6g
abcef7ha43{WEA}7sf6g
abcef7ha43{}7sf6g`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}