using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{((?:[a-f0-9]{2})+)\}";
string input = @"abcef7ha43{aabb}7sf6g
abcef7ha43{aab}7sf6g
abcef7ha43{0008EFAC}7sf6g
abcef7ha43{WEA}7sf6g
abcef7ha43{}7sf6g";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}