$re = '/\{((?:[a-f0-9]{2})+)\}/i';
$str = 'abcef7ha43{aabb}7sf6g
abcef7ha43{aab}7sf6g
abcef7ha43{0008EFAC}7sf6g
abcef7ha43{WEA}7sf6g
abcef7ha43{}7sf6g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);