package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\{((?:[a-f0-9]{2})+)\}`)
var str = `abcef7ha43{aabb}7sf6g
abcef7ha43{aab}7sf6g
abcef7ha43{0008EFAC}7sf6g
abcef7ha43{WEA}7sf6g
abcef7ha43{}7sf6g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}