$re = '/^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$/m';
$str = '10:05am[Mon-Fri Only]
10:05am[Tue]
10:05pm[Wed-Fri]
10:05am[Thu Only]
9:05am[Sat-Sun]
10:05am[Fri]
10:05am[Sun]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);