import re
regex = re.compile(r"^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$", flags=re.MULTILINE)
test_str = ("10:05am[Mon-Fri Only]\n"
"10:05am[Tue]\n"
"10:05pm[Wed-Fri]\n"
"10:05am[Thu Only]\n"
"9:05am[Sat-Sun]\n"
"10:05am[Fri]\n"
"10:05am[Sun]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")