// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$").unwrap();
let string = "10:05am[Mon-Fri Only]
10:05am[Tue]
10:05pm[Wed-Fri]
10:05am[Thu Only]
9:05am[Sat-Sun]
10:05am[Fri]
10:05am[Sun]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}