# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[description\]:((?:.+\n?)*)//;t' <<< " [type]: mail
[category]: Values
[service]: testing
[description]: Testing out automapping of email
Line break Testing out automapping of email
Line break Testing out automapping of email"