re = /\[description\]:((?:.+\n?)*)/
str = ' [type]: mail
[category]: Values
[service]: testing
[description]: Testing out automapping of email
Line break Testing out automapping of email
Line break Testing out automapping of email'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result