# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[description\]:((?:.+\n?)*)"
test_str = (" [type]: mail\n"
" [category]: Values\n"
" [service]: testing\n"
" [description]: Testing out automapping of email\n"
" Line break Testing out automapping of email\n"
" Line break Testing out automapping of email")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.