using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[description\]:((?:.+\n?)*)";
string substitution = @"";
string input = @" [type]: mail
[category]: Values
[service]: testing
[description]: Testing out automapping of email
Line break Testing out automapping of email
Line break Testing out automapping of email";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}