// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[description\]:((?:.+\n?)*)").unwrap();
let string = " [type]: mail
[category]: Values
[service]: testing
[description]: Testing out automapping of email
Line break Testing out automapping of email
Line break Testing out automapping of email";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}