#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<name>name)"
Local $sString = " <students>" & @CRLF & _
" <student name="Raja" age="13" class="6" />" & @CRLF & _
" <student name="Nar" age="15" class'"8" />" & @CRLF & _
" <student name="Mag" age="16" class="7" />" & @CRLF & _
" </students>" & @CRLF & _
" <students>" & @CRLF & _
" <student name="Rex" age="13" class="6" />" & @CRLF & _
" <student name="Nanny" age="15" class'"8" />" & @CRLF & _
" </students>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")