// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<name>name)").unwrap();
let string = " <students>
<student name=\"Raja\" age=\"13\" class=\"6\" />
<student name=\"Nar\" age=\"15\" class'\"8\" />
<student name=\"Mag\" age=\"16\" class=\"7\" />
</students>
<students>
<student name=\"Rex\" age=\"13\" class=\"6\" />
<student name=\"Nanny\" age=\"15\" class'\"8\" />
</students>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}