re = /(?<name>name)/
str = ' <students>
<student name="Raja" age="13" class="6" />
<student name="Nar" age="15" class\'"8" />
<student name="Mag" age="16" class="7" />
</students>
<students>
<student name="Rex" age="13" class="6" />
<student name="Nanny" age="15" class\'"8" />
</students>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end