$re = '/(?<name>name)/';
$str = ' <students>
<student name="Raja" age="13" class="6" />
<student name="Nar" age="15" class\'"8" />
<student name="Mag" age="16" class="7" />
</students>
<students>
<student name="Rex" age="13" class="6" />
<student name="Nanny" age="15" class\'"8" />
</students>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);