import re
regex = re.compile(r"(?<name>name)")
test_str = (" <students>\n"
" <student name=\"Raja\" age=\"13\" class=\"6\" />\n"
" <student name=\"Nar\" age=\"15\" class'\"8\" />\n"
" <student name=\"Mag\" age=\"16\" class=\"7\" />\n"
" </students>\n"
" <students>\n"
" <student name=\"Rex\" age=\"13\" class=\"6\" />\n"
" <student name=\"Nanny\" age=\"15\" class'\"8\" />\n"
" </students>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")