import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>name)";
final String string = " <students>\n"
+ " <student name=\"Raja\" age=\"13\" class=\"6\" />\n"
+ " <student name=\"Nar\" age=\"15\" class'\"8\" />\n"
+ " <student name=\"Mag\" age=\"16\" class=\"7\" />\n"
+ " </students>\n"
+ " <students>\n"
+ " <student name=\"Rex\" age=\"13\" class=\"6\" />\n"
+ " <student name=\"Nanny\" age=\"15\" class'\"8\" />\n"
+ " </students>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}