#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-zА-Яа-я]+([\-`][A-Za-zА-Яа-я]+)*$"
Local $sString = "TheOldName" & @CRLF & _
"the`example`s" & @CRLF & _
"The-new-name" & @CRLF & _
"name`s" & @CRLF & _
"`no-match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")