import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-zА-Яа-я]+([\\-`][A-Za-zА-Яа-я]+)*$";
final String string = "TheOldName\n"
+ "the`example`s\n"
+ "The-new-name\n"
+ "name`s\n"
+ "`no-match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}