$re = '/^[A-Za-zА-Яа-я]+([\-`][A-Za-zА-Яа-я]+)*$/m';
$str = 'TheOldName
the`example`s
The-new-name
name`s
`no-match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);