re = /^[A-Za-zА-Яа-я]+([\-`][A-Za-zА-Яа-я]+)*$/m
str = 'TheOldName
the`example`s
The-new-name
name`s
`no-match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end