package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-zА-Яа-я]+([\-`][A-Za-zА-Яа-я]+)*$`)
var str = `TheOldName
the\`example\`s
The-new-name
name\`s
\`no-match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}