#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1234567890|0123456789|(\d)\1{9}"
Local $sString = "0000000000" & @CRLF & _
"00000000000" & @CRLF & _
"1111111111" & @CRLF & _
"1212121212" & @CRLF & _
"2222222222" & @CRLF & _
"3333333333" & @CRLF & _
"1234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")