re = /1234567890|0123456789|(\d)\1{9}/m
str = '0000000000
00000000000
1111111111
1212121212
2222222222
3333333333
1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end