const regex = /1234567890|0123456789|(\d)\1{9}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1234567890|0123456789|(\\d)\\1{9}', 'gm')
const str = `0000000000
00000000000
1111111111
1212121212
2222222222
3333333333
1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}