$re = '/1234567890|0123456789|(\d)\1{9}/m';
$str = '0000000000
00000000000
1111111111
1212121212
2222222222
3333333333
1234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);