using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1234567890|0123456789|(\d)\1{9}";
string input = @"0000000000
00000000000
1111111111
1212121212
2222222222
3333333333
1234567890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}