import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1234567890|0123456789|(\\d)\\1{9}";
final String string = "0000000000\n"
+ "00000000000\n"
+ "1111111111\n"
+ "1212121212\n"
+ "2222222222\n"
+ "3333333333\n"
+ "1234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}