#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif))"
Local $sString = "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")