import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:https?)+\\:\\/\\/+[a-zA-Z0-9\\/\\._-]{1,})+(?:(?:jpe?g|png|gif))";
final String string = "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif\n"
+ "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}