# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif))"
test_str = ("https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.