// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif))").unwrap();
let string = "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}