re = /(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif))/im
str = 'https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end