package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][^,]+),\s([A-Z]{2})`)
var str = `Fort Worth, TX
This is Forth Worth, TX
We are looking for someone from Columbus, MS.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}