const regex = new RegExp('([A-Z][^,]+),\\s([A-Z]{2})', 'g')
const str = `Fort Worth, TX
This is Forth Worth, TX
We are looking for someone from Columbus, MS.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}